All systems say error: no such host is known

I do not know why and not sure when exactly it started but i can no longer use right click tools to do many things on a remote system anymore. i mainly use it to update machine policy and all my systems i do it on now report back “Error: No such host is known”. in a command lind i can ping the systems in question, i can also do nslookup and a reverse lookup of the systems as well. i really would like to get this working again and i do not know why its broken

Hi there! To be sure can you attempt to update or redownload Right Click Tools and let us know if the issue persist?

i downloaded and installed the tools again and i am still getting the same issue

No such host is typically known as a DNS error, indicating that the name of the device that ConfigMgr has could not be resolved in DNS. Could you try to flush DNS or turn off the use FQDN option and see if the issue persist.

so i have done that and i modified the setting you said and it still is not working. i am going to attach a pic where you can see the sccm server can ping and nslookup the system without issue but the right click tool fails with the same error

I have had that happen where I work. There have been several reasons but when it happens in a wide spread situation it has been. Symantec Endpoint Protection antiVirus blocking many things that require communication to the SCCM Client. Often this issue reappeared when an updated SCCM Client was deployed. (A real POS and terrible support from Symantec IMO.) Manually uninstalling the Client and reinstalling it using something like PSExec.exe resolved it for a while.
When only impacting a few systems a corrupt Firewall on PC was the issue.

1 Like

thanks for the info but i can’t go uninstalling and re-installing thousands of agents. there has to be a better way to fix this and a reason for it. i get that i have the free version but many times i have talked about getting the paid version, but if this is what is going to happen i just can’t plunk down the big dollars for this. I also cannot gauge how there support would be after i did pay for it based on the lack of support from them here

this this is seriously messed up and i do not even know where its getting its information from. i tried to use the right click tools to connect to an interactive command prompt and a command windo came up and it was trying to connect to which is not the address of the system. on the same server i opened a command prompt and pinged the system and it returned the correct IP address. so it obviously not using the system own cached DNS information and where its getting it info from i have no idea