Community prompts about license expiration


I’ve downloaded and installed the latest Community version. Now every day when I’m using it for the first time a message pops up claiming my license is expiring. I know, that I can disable this prompt from the control panel, but I’ve never seen this before with the earlier versions of the RCT Community.

So have I somehow managed to download the Enterprise version, or why this message appears?

3.2 includes a free 30 day trial of the enterprise tools.

1 Like

Is there any way to get this warning popup to stop appearing? My company is not planning to invest in this software so I hope that is not the answer. If you can’t make the warning stop, then I’ll probably discontinue use of this software.

You can use the “Show License Expiration Prompts” option in Configure Recast RCT.

The free version doesn’t seem to add anything to Control Panel. I just got off the phone with Garrett at Recast and he says there is no way to stop the free version from displaying this message but it will stop on its own 30 days after installing the add-on.

The installer should add the following entry in the Control Panel.

The Show License Expiration Prompts option I mentioned above should stop the warning messages from popping up.

When I hit Modify, a Recast RCT Setup window appears for a few seconds, acting like it is installing something and then all you can do is click a Finish button. I’m not presented with any type of interface like you have shown above. It’s OK, I’ll wait for the 30 days.

Sorry, I should have specified above. Configure Recast RCT can be accessed from your Start menu.

Ah, there it is! I found it on the Start Menu as you suggested and deselected “Show License Expiration Prompts”.

Thank you so much for your help on this!

Is there anyway to automate this setting by changing a registry value or change a setting in a file?

I want to deploy Recast RCT to some users with this option OFF (default is on) by default using System Center.

This should be off by default on fresh installs, but older versions had it on by default and the installer doesn’t change existing settings. You can work around this by configuring it the way you want and copying the %AppData%\RecastRCT\ManagementDB.sqlite file after the install.

I’m still getting the license prompts even with this fix. My settings show the license prompt box unchecked, but I still get the prompts. I am using the community tool version 3.2.6887.24316.

Do you launch the ConfigMgr console as a different user? If so, could you try launching Configure Recast RCT as that same user to make sure the box is unchecked?

Ahhhhh…the GPO won’t put down the corrected file until I actually log into the PC with that ID (which I never do; only ever run-as that ID as will the rest of our users of this app). Is there no other way to silence the license prompts programmatically?

You could delete the enterprise trial license from C:\ProgramData\Recast Software\Licenses. It should be a .license file named with a GUID.

I’m not sure that works for an enterprise scenario because the GUID appears to be different for each install. Is there just a command line switch I can use to tell it not to do the Enterprise Trial at all so we don’t have this issue to begin with? If that’s not available now, can that be added?