Device Collection Tools missing after upgrade to MEMCM 2010

So now that MEMCM 2010 has been released I can post this question, hoping some of you are already on 2010. Currently in our environment (running an early build of 2010 as part of the TAP Program), after the upgrade it seems that the collection tools (e.g. to add users to a collection) no longer show up when right-clicking on a device collection. This is with version 4.4.2010.3401 (Community version).

All of the other tools are still working fine though. Tested this on multiple devices, all having the same issue. Anyone else seeing this on MEMCM 2010?

Hello! I just tried this in our Dev environment (Running MEMCM 2010) and everything seems to be working for us with collections. It almost seems as if the MEMCM console update wrote over some of the additions that Right Click Tools makes to add the menus in your environment.

Have you tried uninstalling and reinstalling Right Click Tools? I would expect that doing that would reset everything back, and then make the needed changes upon reinstallation.

Hi martym!

Yes, I have tried uninstalling and reinstalling. I actually tried it again just now and even cleaned up whatever folders were left in ProgramData etc., also made sure nothing was left in the registry, and then did a clean install.
Still nothing showing up when right-clicking a collection.

Weird thing is a few of my team that also have RCT installed have the same issue.

Can you send some screenshots of what you are seeing to We’d love to see what you are experiencing. Thanks.

Did this ever get resolution? We just upgraded to MECM 2010 and are seeing the same thing.

I have sent over screenshots.

We too are seeing the same issues on multiple devices. Tried uninstalling/reinstalling and also downgrading to 4.4 with the same results on MEM2010.

Are there any updates ?

Many thanks.

Thanks for your patience, we have identified the issue, and a fix will be available in the next version of Right Click Tools.

The issue is occurring because somewhere along the line Microsoft changed the GUID for the collection right click menu for some users. We’ve added that new GUID in the installer for the next version. To get the tools working now, you can do this:

Rename the directory C:\Program Files (x86)\Microsoft Endpoint Manager\AdminConsole\XmlStorage\Extensions\Actions\a92615d6-9df3-49ba-a8c9-6ecb0e8b956b
And change that GUID directory name to e92615d6-9df3-49ba-a8c9-6ecb0e8b956b

After that, restart the ConfigMgr console and that should allow the collection Right Click Tools to appear again. (Or you can wait for the 4.5.2101 release of Right Click Tools)


Another workaround is opening the collection you want to use RCT on and then in the left side menu under Devices where the collection temporarily gets added, you can use RCT as normal.

Given that only the first character of the GUID changed I wonder if this is a typo by a Microsoft developer in specific builds of MEMCM 2010 and they actually didn’t mean to change the GUID.

Also for me the directory path is C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\XmlStorage\Extensions\Actions\a92615d6-9df3-49ba-a8c9-6ecb0e8b956b, so it could also be just an issue if you kept updating your console rather than a fresh install of the MEMCM console, that could explain why some people have the issue and others don’t.

The rename of the GUID has worked for me and others in the team. Thanks for the super quick response.

Hello! I just built a new MEMCM lab on 2110 tech preview, and downloaded the latest RCT Community edition, and it’s doing this same thing (not showing up in the console). I tried renaming the GUID from “a” to “e” as described above and restarting the console, but still not showing up. I see the “console extensions” feature only recognizes .cab files for importing. Is this going to change how extensions work going forward?

Hello! Can you verify that your tools are missing completely? or just for the Device Collections? Microsoft did make some changes, and now you have to approve legacy extensions to show in the console. See if this help The Right Click Tools do not appear in the ConfigMgr console after installation

Hi Martym - I’ve been in touch with Bryan and provided him with some information about my lab setup to help with this. Please let me know if you still need any other information. Thank you!