Error - Computer is not on

I’ve updated to the latest version (4.0.7180.924) and now when ever I try to do anything I get an error that the computer “was not on”. Example would be connecting to C$, I can manually open explorer and type it in and it works fine, but going through RCT I get the computer was not on error. This happens with everything in RCT now.

Log file entry:

2019-08-30 15:11:34,264 [1] INFO Recast.RCT.ConfigMgr.App OnStartup() - Version: 4.0.7180.953
2019-08-30 15:11:34,280 [1] INFO Recast.RCT.ConfigMgr.App OnStartup() - Arguments: -tool=0a914a13-50a3-49f8-bffd-7b07ed6fed2e -parameters=C:\Users<username>\AppData\Local\Temp\RecastRCT\nduvawxy.vzo
2019-08-30 15:11:35,651 [4] INFO Recast.RCT.Server.RecastRCTEnterpriseServer LoadPlugins() - Plugin Count: 23
2019-08-30 15:11:36,376 [20] ERROR Recast.Software.Loader.LicenseLoader ActivateLicense() - Failed to activate license
System.IO.IOException: The process cannot access the file ‘C:\ProgramData\Recast Software\Licenses\74ac6420-0662-45af-ba39-2a20d8187d7d.license’ because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
at System.IO.StreamWriter…ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
at System.IO.File.InternalWriteAllText(String path, String contents, Encoding encoding, Boolean checkHost)
at System.IO.File.WriteAllText(String path, String contents)
at Recast.Software.Loader.LicenseLoader.d__11.MoveNext()
2019-08-30 15:11:45,698 [1] WARN RCT.Plugin.Device.OpenFolder.OpenDeviceFolderBase Execute() - was not on

I noticed the same issue about a month or two ago.

I’ve noticed the same thing. I can confirm the device pings through command prompt but, RCT thinks its not on

There are a number of reasons Recast might report the device is not on:

  1. The device is not responding to ICMP echo requests. This is the most common reason for this error and can be fixed by allowing ICMP echo or by disabling the “Ping Computer Before Running Tools” option in Configure Recast RCT.
  2. DNS is not resolving the correct IP address. The “Use FQDN instead of computer name when connecting to computers” setting in Configure Recast RCT can be used to switch between FQDN / short name for DNS resolution - some environments will need the FQDN and some will need the short name. If DNS is too unreliable, we have also have an option to “Use IP Address Instead of Computer Name”. I’d recommend using the “Verify Computer Name in WMI” option if the use IP option is selected, as it’s much easier to run an action against the wrong machine in this configuration.
  3. .Net maintains a process level DNS cache. If you’re using the “Run in ConfigMgr Console Process” option and keeping your console open for long periods of time, it may cause stale records in the .Net process cache. You can try unchecking this box so that every launch of a Recast action starts in its own process.

If none of this is working, you can disable the “Ping Computer Before Running Tools” option to completely remove the “Computer Is Not On” error messages. In this configuration, Recast will not ping the device before trying to run the action. The downside is that failures may take a bit longer to report when devices are offline or not responding.

Hope that helps,

Thanks for the response Chris. I’ve removed the “ping computers before running tools” but the issue still persists. The older version I had did not have this issue. Is it possible that the setting for ping is not shutting off? Is there a registry key or .ini file that can be checked to make sure the ping setting is actually turning off.


Could you send all of the files in %AppData%\RecastRCT to so we can dig into it some more?