Interactive Command Prompt - fails to launch console

I am looking for some advice.

The issue is
when I select “Interactive Command Prompt” it launches the console which immediately closes.

I am using RCT 2.5 Free.
RCT is configured to point PsExec.exe correctly.
I have tested PsExec connects independently ( psExec \\computer cmd )

I dont find anything useful in the RCT logs (guidance here is welcome) .
“Interactive Powershell Prompt” works in the same scenario (indicating it is not a problem with IP, firewall or permissions )

Any suggestions ?


Have you tried upgrading to the latest version, 3.1? 2.5 is an old version and no longer supported.

Hi Mark,
I am working with version 3.1.6689. The latest free version.

Are you launching your tools as a different user account? The PSExec path is stored per user, so Configure Recast RCT would need to be launched as the user that the ConfigMgr console is launched as. It might also be worth checking that the user running the console has permissions to the path that PSExec is stored in.

Hi Chrism,
I am running the console as a user with rights to the local psexec path and rights to connect to connect to the remote machine (where that user is part of the admin group of the remote client).
If I run psexec via the command console as the same user I can connect.

I have the same problem. PSEXEC Console comes not up. How can i solve this problem?

Confirmed here as well with 3.2.6962.38904 and SCCM 1810.

FYI, Interactive PowerShell Prompt stays open but it fails because it needs to run with admin rights.

Could you try downloading the tools again and let us know if it works any better? We have a new version (3.2.7026) that should fix some bugs with the interactive command prompt tool.


:persevere: Yesterday i tried with the old version (3.2.6962.38904).
Today i upgrade to the newest one (3.2.7026.33608).
The newest version fixed the problem :smiley: thank you very much :pray:
Next i read the release notes in more detail. :man_facepalming:

Thanks did not see 3.2.7026.33608. Got it. Confirmed, window stays open but it still needs admin rights to function. Without I get “Access is denied.”

Same goes for the PowerShell prompt. Must run with admin rights or fails with same “Access is denied…”

Basically just need to kick in UAC when opening the prompts.

Thank you!

Maybe your account isn’t admin on the device you want connect? I got the same message, but if i use a account which is in the admin group the connection works. In my case i have to accounts. So i open the sccm console as different user and use my admin account.

My account is a domain admin.

It’s always the case that admin rights are required for remote access.

By default UAC drops the creds to normal access request. RCT simply needs to launch the cmd window asking UAC for admin rights.

Well apparently this has changed on Win10 1903. It’s working now, even without admin rights. :slight_smile: