"Method not found" when RMS is configured in Recast RMS

Hello. We recently updated Recast Management Server and we are receiving Error:
Method not found: ‘System.Threading.Tasks.ValueTask System.Threading.Channels.ChannelWriter`1.WriteAsync(!0, System.Threading.CancellationToken)’. This error is in console, when I click on content distribution monitor or BitLocker Compliance or Active Directory Cleanup. Remote Software Center Applications and Software updates shows nothing (it is empty). On the RMS web portal, nothing is showed in graphs. When I disconnect RMS in Recast RCT Config, everything works. Problem is, when I set Recast RMS only. Can You, please, point me, where should I search to resolve this issue? We tried to reinstall Recast RMS, create new database for it, but it didn’t helped. Thank You. I’m not skilled in .NET. :frowning: .

Hey there,

Is this also after updating to Config Mgr 2207 by chance?
If so, when you have a second, can you please follow the instructions here: Configuration Manager Version 2207 Compatibility | Recast Docs and let us know if the issue is resolved after?

If it’s not on 2207, can you verify if you’re also using the Ivanti plugin? If you are, can you please update the Ivanti plugin and verify if the issues resolve?




Hi Branden,

Thank You very much. Yes, this was related to 2207 MECM upgrade and Your solution works perfectly. Thank You. Everything in MECM console works now. You saved us from terrible headache :slight_smile:

Other issues with RMS (empty graphs on the web and so on) were resolved by installing .NET Updates from Microsoft Update. Server with MECM and server with RMS had different .NET updates installed. Both were updated to the latest versions and the RMS started to work again.