RCT 4.9 Schedule Restart or Shutdown

Hello there. We are trialling the community version of Right Click Tools to see if the enterprise version is what we need.

So far I have been able to schedule restarts on our servers without issue.
But this month, I get the below error when I click “start” after filling out all the time/date etc on the dialog box:

Error: The scheduled task creation did not return a process ID.
Return Value: recast.RCT.Server.Plugins.Abstractions.CimInterfaces.RecastCimMethodParameter

I have attached a screenshot also:

This worked last month without issue.
The version we are using is:

Desktop installed version: 4.9.2210.3002
Server installed version: 4.9.2210.3001

Any help would be greatly appreciated.
Thank you

Hi Eugene,

Hope all is well! When you have a second, can you send a screenshot of the values that you’re filling in for the time/date dialog box prior to submitting? I’d like to see if I can potentially recreate the behavior in our test environment.



Hello Branden,

No problem. Screenshot is attached.

Hi Eugene,

Could you change “Date Format” to MMddyyyy and attempt to schedule the restart again?

I’ve noticed in my test environment there are some issues with ddMMyyyy format. Even though the date format is not the same as in your Start Date value, the restart will work correctly

Hello Aapo,

I get a different error when I try that:

Error: Create scheduled task failed with exit code 2147500037

Hello Aapo,

Has there been any update on this issue?

Hi Eugene,

Apologies for the slow response! Could you share RCT log files from your device from %APPDATA%\RecastRCT\Logs folder to our support: support@recastsoftware.com? In the support email, could you also share us your operating system’s region format (short date & short time)?

Before sending the log files, could you try to schedule the restart with other “Scheduled Task Options” and “Restart Options” to see if changing those makes any difference?

Hello Aapo,

No problem. I have attempted a few different scheduled restarts and captured the logs files.
I’ll email them now.

For future reference, the issue was solved by enabling “Use IP Address Instead of Computer Name” option in Configure Recast RCT app:

My organization is experiencing this same behavior. We are largely using version 4.8.2110.5301, and suddenly starting to get multiple failures of scheduled restarts with the same error message. The Scheduler.log displays the following:

2023-01-12 08:02:07,215 [17] ERROR Scheduler reportProgress()
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: The scheduled task creation did not return a process ID. Return Value: Recast.RCT.Server.Plugins.Abstractions.CimInterfaces.RecastCimMethodParameter
   at NowMicro.Recast.RCT.Server.Plugins.SystemInformation.SystemInformation2.ScheduleShutdown(String name, Boolean restart, Boolean skipIfUserLoggedIn, Boolean giveUserPromptToCancel, String taskName, DateTime startDate, ScheduleFrequency frequency, ScheduleModifier modifier, DateFormat dateFormat, ISettingProvider settingProvider, IRecastCimSessionProvider sessionProvider, Int32 delay, String userMessage, Nullable`1 endDate)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Recast.RCT.Server.Plugins.PluginBase.AttributeRecastAction.<RunAction>d__65.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
   at Recast.RCT.Server.Plugins.Scheduler.Async.ChildJob.<Run>d__16.MoveNext()

We upgraded to 4.9.2210.3302, but receive the same behavior across multiple target endpoints, and SCCM technicians working from different stations. Executing mass restart via straight powershell (bypassing RCT) succeeds, and CANCELLING restarts with RCT (says that it) succeeds without error.

The proposed solution of ‘Use IP Address Instead of Computer Name’ did not resolve the issue in our case.