RCT Install 1612 error

We are experiencing issues when attempting to install/distribute the MSI install for RCT via ConfigMgr. It always results in a 1612 error-

SOURCEMGMT: Source is invalid due to missing/inaccessible package.*
SOURCEMGMT: Failed to resolve source
MainEngineThread is returning 1612

It appears the MSI is attempting to use the LastUsedSource from the Sourcelist instead of resolving the source of the MSI’s current directory.

We have tried using the SourceDir property at the command line, and we have tried adding the ResolveSource Action using a transform but with no success.

Any ideas? The MSI installs fine if we just run it manually.


We found that some of our devices have a registry key for RCT at “HKLM:\SOFTWARE\Classes\Installer\Products” that have the source property set to an old ccmcache location. Which is very strange because these devices absolutely have never had RCT installed at any point. Not sure how that key came into existence. We added a line in our install script to look for and remove that key if it exists, and the installs are working.

Any idea how that key gets generated on devices that don’t have any existing install of RCT or the ConfigMgr console?

Hi @dcartis ! Thank you for letting us know about this issue. We’re happy to hear that you were able to self resolve it and get the tools installed. Could you verify what version of Right Click Tools you were attempting to deploy? I’ll see if we can recreate this issue in our test environment and let you know what we find out.