RCT Install Error - PowerShell V3

I have just downloaded the latest RCT installer (4.0.7191.38749) and am unable to get it installed.
I receive the following error:

I am running Windows 10 1903 and have tested on other machines (also running 1903) with the same result. Any ideas?

Could you run the installer with the following switches and send the resulting log file to support@recastsoftware.com?

msiexec /i <pathToMsi> /lv log.txt

The log has been sent.

Has there been a resolution to this? I’m receiving the same error on 2 different devices.

Hello, Is there a fix for this? We’re experiencing the same problem on several devices.

Hi there! Can you try running the installer from an administrative command prompt? That should resolve the issue.

Thanks for reply. I should have listed what has been tried all ready. The new RCT agent successfully uninstalls the old version, but can install the new version. And whats sucks, you can’t rollback to an older version of RCT

  • Installing from a admin cmd prompt doesn’t work.
  • Installing from SCCM doesnt work.
    *uninstalling and reinstalling (manually) doesn’t work.
    *Reinstalling the previous version doesn’t work either.
  • Not seeing anything in the registry.
  • Cleaned all RCT components out of the OS
  • Removed the CM admin console, then reinstalled the admin console didn’t help.

Out of 30+ RCT installs, 3 are experiencing the PS 3.0 problem. 2 OS are 1902 and one is on 1703, Windows 10.

UPDATE: Success

 When trying to pull some logs I inadvertently ran  - msiexec /i "Right Click Tools-4.0.7230.35407.msi", and the install worked. But when running without msiexec /i, I always got the PS pesky error message. I'll try this on the other 2 devices today, see if it works.

And btw - this is the same string I have in my app package (msiexec /i “Right Click Tools-4.0.7230.35407.msi” /q) and it doesn’t work on the 3 of the 30+ PC.

I am also having this problem.

Same. I thought I purge this problem, now its back on a few devices.

I HAD this error but for me I was able to launch Command Prompt as admin and then ran
msiexec /i “Right Click Tools-4.0.7230.35407-132159045992795058.msi”
numerous other installs failed but this way worked for me first go.

Did this ever get a resolution? I’m seeing the same prompt to install WMF on the 4.5.2012 install. Looking at the log, It keeps dumping out of the installer at around this point:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C:\Program Files (x86)\Recast Software\Recast RCT\Default Menus\Device_Recast Enterprise Device Tools.xml’.

Before this, it was missing the folder “Default Menus” and then “Default Nodes.” I can probably copy the remaining missing documents and folders over from a working install, but that’s working around a problem that shouldn’t exist, no?

Hello! The workaround for the Powershell v3 error has been to run the installer from an administrative command prompt. Are you getting an error even after the install has started with this method?

I’m afraid so. uninstalled RCT and then tried it. And then I un-installed the CM console, re-installed and then tried the elevated cmd prompt. Same issue. It’s an odd one.

Can you run the installer with verbose logging and send the resulting log file to support@recastsoftware.com? It would be great to follow what’s happening in the install logs. Thanks!

Did this issue ever get a solution? I’m having the same problem as above trying to install Right Click Tools-4.7.2106.1601-132687686679910553.
Any ideas?

Still getting the same error on -
Right Click Tools-4.7.2107.2301-132718049334093733.msi



I was able to locate several REGKEYS that apparently were left over from the previous uninstall located here:





HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Tracing\Right Click Tools Desktop_RASAPI32

HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Tracing\Right Click Tools Desktop_RASMANCS

After deleting these keys the installation for version 4.7.2107.2301-132718049334093733 worked without prompting for the Powershell version 3 update.