RTC Runner What context is it run in? Elevated permissions?

RTC version both client and server = 5.0.2302.1703
MECM 2203

My Question is what account does the RTC use when running an action in Recast Runner?

I have an action that runs a PowerShell script that copies a folder from a network share to the a folder on the system drive. The script runs but can’t preform the action because of permissions issues on the folder. My account is a local admin on all clients, We have a proxy account that has the same rights that I have. I have Route with the Proxy account above Console extension. I have tried moving the Proxy around in the Routes.

When I run the script from the ISE with elevated rights the script runs properly, If I add Modify rights to the folder, the RTC Action runs properly, I know the script works.

It looks like the account that is running the process uses non-elevated rights.

Hi Mark,

Hope all is well! It depends on your routing but it’s most likely using the account credentials that are signed into the console or the account credentials for your Recast Proxy. When you have a second, can you email support@recastsoftware.com a screenshot of your routes tab and also share the builder action you’ve created? This guide will walk you through exporting the action: Import/Export Builder Actions | Recast Docs. Please let us know if you have any additional questions.