Sccm 2111 ; rct 4.8.2110.16001 from console

Upgraded our environment from SCCCM 2107 to 2111 last week. We have been using the RCT Console extension from WITHIN SCCM for several revisions now.

Today I went to “update” the RCT in SCCM and it shows it updated successfully but when I attempt to install the extension on a console I receive an error that the “manifest doesn’t exist in the cab”


AdminUI.ExtensionInstaller.exe Information: 0 : Found 1 extensions need install/update.
DateTime=2022-03-15T12:30:12.3704531Z
AdminUI.ExtensionInstaller.exe Information: 0 : Applying Extension 99429045-5ed9-42f0-992b-d73f628e6131 Version:4.8.2110.16001
DateTime=2022-03-15T12:30:12.3704531Z
AdminUI.ExtensionInstaller.exe Error: 0 : Unable to install extension:99429045-5ed9-42f0-992b-d73f628e6131 because it is an invalid extension. Exception:Microsoft.ConfigurationManagement.AdminConsole.ExtensionInstaller.InvalidCustomExtensionException: Unable to validate 99429045-5ed9-42f0-992b-d73f628e6131:4.8.2110.16001 because Manifest doesn’t exists in the cab.
at Microsoft.ConfigurationManagement.AdminConsole.ExtensionInstaller.CustomExtensionInstallerBase.ValidateFiles(List1 customExtensionFiles) at Microsoft.ConfigurationManagement.AdminConsole.ExtensionInstaller.CustomExtensionInstallerBase.Install() at Microsoft.ConfigurationManagement.AdminConsole.ExtensionInstaller.CustomExtensionHandler.InstallExtensions(List1 extensionsMetadata)
DateTime=2022-03-15T12:30:12.4863139Z

I removed the RCT extension from SCCM and redownloaded from GIT and approved in SCCM but am still getting the same error.

In the console, in the Community node in SCCM, if I search for RCT it shows available to download (not listed under “Your Downloads”) but if I try again to download it, it says " Download failed. The item already exists on the site.". If I look in the Administration Node it shows listed as “approved” in the Console Extensions.

I am using an account that is both SCCM admin AND local admin on the workstation.

SCCM Console version: 5.2111.1052.2500
Site Version: 5.0.9068.1000
RCT Version (FROM SCCM CONSOLE) 4.8.2110.16001

Installing RCT from MSI is not an option within our ORG.

As a side note, I tried AGAIN to remove the console extension and then I rebooted our primary server. Then I went again to download the console extension from the Community Node. Receive the following message:

but go to the Administration Node and the extension shows as there:

Go again to the Community node and try to download again and receive the message that the item already exists

(sorry for the multiple replies, I can only upload 1 image per message)

Hi there,

Thank you for reaching out! This is a bug that our dev team is actively working with Microsoft on to get resolved. Until the bug is resolved, please install Right Click Tools using the MSI available at https://portal.recastsoftware.com.

Thank you for your patience.

Best,

-Branden