Error: Enumerator failed


I seem to keep getting the following error:

Error: Enumerator failed to MoveNextAsync

I’ve tried the following clients:

Right Click Tools-5.1.2303.1708-133252047141005430

Right Click Tools-5.1.2305.507-133281324536319123

It happened on both sccm 2211 and 2303

I did find another post describing a similar problem and they mentioned they had a previous version (4.9) which resolved their issue.

Is there a link/repository that has previous versions I can try, I did have a look but was unable to find any.

I’m also experiencing a slow console when the tool is installed, there was a post on reddit from one of the devs mentioning a workaround called “Skip in console check” but I don’t see that option in the new installer, the reddit post was a few years ago though

Thanks for any help or advice!

Hi there,

You can get the 4.9 version from under archived releases.

Just to confirm, are you encountering that specific error only when attempting to rerun deployments or in other scenarios as well?

When you have a second can you close the ConfigMgr console, add this registry key to enable debug logging, open the console and run the actions throwing the errors, and then send the Recast Console Extension log files that are generated in C:\Users\UserAccount\AppData\Roaming\Recast Software\Logs? to

Does overall performance of the console improve if you uncheck “Run in ConfigMgr Console Process” and reopen the Config Mgr console?



Hi Branden,

I cant seem the find the regkey but the error comes up no matter what option I do (push machine policy, restart machine etc).
I do have a logfile there and was going to send over but perhaps it doesnt have the info you need in it?

I didnt even think of going into the “Recast Software” menu to have a look around. When I uncheck “Run in ConfigMgr Console Process” then try to click save…I get the same error:
“Enumerator failed to MoveNextAsync” error
However I can click away, close the window and when I go back in it is still unchecked even after I close and reopen the console.

Do you want the logfiles anyway if not no worries I more than happy to install a previous version.

No problem. If this is happening for all actions, can you verify if the issues resolve if you uninstall right click tools using Fix problems that block programs from being installed or removed - Microsoft Support and then reinstall the same version?

You’re also welcome to install the previous version as well if you’d like, but the latest version should work for you as well and we’re happy to troubleshoot with you.